Wazer Not Turning On

I have a Wazer in my makerspace that is currently not turning on. I have tried every troubleshooting action I can think of to no avail. Any advice?

@kcplidealab , have you tried wiggling the floats in the right rear of the Wazer above the filters under the back cover? Ours like to get twitchie and I need to jiggle all of those floats and just run my fingers over the long filters a touch. That helps mine. It usually happens to me when I clean it out and add water.

My first thoughts are fill level. To high or two low. Second is the power supply. Separate outlets.

Hey kcplidealab, sorry to hear your running into this issue. There are a few different things that could prevent the WAZER from turning on, the first thing to check into is the water level in the tank. Where is the water level at now? There are safety features that will cut power if it gets too high or too low!

Try filling the tank so that the water level is about even with the cut bed surface, if this doesn’t allow the WAZER to turn on open up a ticket by emailing us at support@wazer.com so that we can help to get you up and cutting!