SVG imported into WAM different size than drawn

I’ve drawn a simple 6" diameter circle in Inscape and imported it into WAM yet in WAM in the scale info it shows the the “scale” as 6.3636 wide and 6" high? If I convert the SVG to a DXF and import it into WAM it is 6" x 6" so it is only having a problem with an SVG! I tried a 6" square and had the same problem and then tried a complex shape and also had the same problem. Any ideas?

if you open the svg file with a text editor, at top there should be a line about scale.

<svg width=“130mm” height=“100mm” viewBox=“0 -100 130 100” version=“1.1”
<g transform=“scale(1,-1)”> <—SCALE

You can also see the width/height in mm right there.

I wonder if your export is actually scaled.

Thx for the reply and suggestion. I Checked the file via notepad and height is 6.0000 and width is 5.99999 so no scaling in Inkscape, also, If I import the svg into Fusion 360 it is 6” dia. As expected which suggests that Inkscape is not the culprit.

Do you mind sharing the SVG file here so I can take a further look?

My first thought is there is a bug in WAM that is showing the incorrect WxH after adjusting the scale and/or location when done in a certain order. This is an old bug and I will need to jog my memory of it exactly so don’t take my word for it yet without me being able to dive a little deeper and work with the SVG file itself haha

Happy to provide the file.
6-in circle

I actually discovered the issue when I cut the 6" circle and realized it wasn’t round so it isnt just showing the incorrect WxH. In testing it again with squares and other geometric shapes the size difference is even before any positioning occurs so doesnt seem to be a function of operation order.

I opened your file in QCAD, and its 6.364" across.

Unless I’m doing something wrong. it is a circle, but appears to be larger than 6"

That’s interesting. So QCAD says it is a circle but of dia of 6.364. Inkscape (text file) says it is 6.0000 high and 5.9999 wide so essentially a circle of dia 6. The Inkscape display says it is a circle of 6" and using the inkscape measuring tool it says 6" across and 6" high When it is inserted into Fusion 360 it remains a circle. But bringing it into WAM it says 6.3636 wide by 6" tall???