Blank GCode Files

A few weeks ago, I’d taken my SD card to the studio, preloaded with WAM files created in the usual way (I use Inkscape)

One of the files, when I tried to open in on the Wazer just gave a blank screen. At the time, I wondered if perhaps I’d just whipped the SD card out the laptop too quick or something, so I recreated a WAM file and did it the next day.

Yesterday, I had the issue happen again, but this time I had my laptop with me, so I created the WAM file again, repeated the process, carefully, and still the same

I now always quickly check my gcode in NCViewer as I’d accidentally created a couple of files with a double cut (I think I’d exported stroke to path and it had drawn the inside and outside line perhaps?)

Anyway, I’d already checked this file, and the gcode was present, but the file came up blank

When I looked at the file that wouldn’t’ work before, there was a common theme

It was a multiple shapes created in one file in Inkscape (so, say it was a circle with a hole, instead of importing 10 individual circles into WAM, I created the set of ten in Inkscape, already laid out, so I only have to import one file to WAM)

In both cases, I used the same original SVG in Inkscape and just duplicated it, several times

It appears in WAM okay, the when I run the gcode through NCViewer, it all looks okay too.

I found another file where I’d created a single shape, then also created an Inkscape SVG with multiples on one set, but when I opened that file on the SD card, it showed as normal.

I am not sure what I am doing wrong, but I am guessing it’s something I am doing wrong?

Yesterday’s fine was a circle within a circle, so generated using Inkscape geometric shapes, and just repeating a single file (which will cut). The previous file that was blank, I’ve just checked, was the same thing, multiple circles. The multiple file that did work was a more complex shape created from several geometric shapes and lines put together (I do know if this is relevant, but it seems odd that it was a multiple circle circle one that won’t open in the WAZER. I’ve also created a multiple stars one in Inkscape, that will import into WAM fine, and the gcode is fine, but I’ve not tried opening that file on the Wazer yet as I don’t have the glass prepared.

Hoping it’s something easy to fix/sort out.

Thanks in advance.


1 Like

I am having the same problem I think. Put the WAM generated gcode on an SD card, but when I tried to open it on the wazer it was a blank screen. Did you find a cause/solution?

Hi, if I remember rightly, I’d simply forgot to covert object to path, in Inkscape

It doesn’t happen every time, so it must be something to do with whatever is used to drawer the shape in the first place